0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Функция ЕСЛИ в EXCEL

ЕСЛИ(лог_выражение;значение_если_истина;[значение_если_ложь])

Функция имеет 3 аргумента.

Лог_выражение — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. Например, выражение A1>100. Если в ячейке А1 содержится значение 102, то выражение A1>100 вернет ИСТИНА, т.к. 102>100. Если в ячейке А1 содержится значение 88, то выражение вернет ЛОЖЬ, т.к. неравенство 88>100 неверно. Полностью формула может выглядеть так =ЕСЛИ(A1>100;»Бюджет проекта превышен»;»ОК!») Если в ячейке A1 содержится значение большее 100, то формула вернет текстовое значение Бюджет проекта превышен, а если меньше 100 или равное 100, то будет выведено ОК!

Других значений кроме ИСТИНА или ЛОЖЬ логическое выражение вернуть не может. Любое число кроме 0 в первом аргументе будет преобразовано в ИСТИНА, ноль — в ЛОЖЬ. Если ошибочно будет указано текстовое значение, то функция вернет ошибку #ЗНАЧ!.

Примечание : Ошибка #ЗНАЧ! может быть также из-за ошибок в выражениях указанных во втором и третье аргументе.

Второй аргумент — Значение_если_истина и третий аргумент значение_если_ложь

Как было показано выше, если логическое выражение (первый аргумент функции) принимает значение ИСТИНА, то функция возвращает значение из второго аргумента значение_если_истина. Соответственно, если логическое выражение принимает значение ЛОЖЬ, то функция возвращает значение из третьего аргумента значение_если_ложь .

Второй и третий аргумент могут быть любым значением (число или текст) или являться выражением (формулой с функциями). Например формула =ЕСЛИ(A1>100;0;А1*1%) позволяет вычислять премию для проектов, в которых не было превышения бюджета (>100). Если бюджет превышен (в А1 введено значение 200 или любое другое более 100), то формула вернет 0, если в А1 введено значение менее 100, то будет вычислено значение премии А1*1% (т.е. если в А1 число 90, то формула вернет 0,9).

Читать еще:  Обещанный платёж МТС — как получить деньги в долг при минусе

Если в качестве второго и третьего аргументов введено выражение, то оно может содержать и функции, например: =ЕСЛИ(A1>100;СУММ(B1:B10);СУММ(C1:C10)) Т.е. если в ячейке A1 содержится значение >100, то суммирование ведется по столбцу B , а если меньше или равно 100, то по столбцу С . Не забывайте, что при значении А1 = 100 в данном случае будет срабатывать выражение из аргумента значение_если_ложь.

Аргумент значение_если_ложь можно опустить (не вводить), тогда при значении логического выражения =ЛОЖЬ будет выведено ЛОЖЬ. Например, если в А1 содержится 600, то формула =ЕСЛИ(A1>=1000;»Больше или равно 1000″) вернет просто ЛОЖЬ. Понятно, что при значении логического выражения =ИСТИНА будет выведено «Больше или равно 1000», т.е. второй аргумент функции ЕСЛИ() — Значение_если_истина.

Инструкция

  1. Для того, чтобы поменять обозначение колонок в программе Microsoft Office Excel вам нужно установить специальные настройки в нем. Стоит понимать, что изменение нумерации колонок будет записано в сам документ с таблицей и открытие данного документа на другом компьютере или в другом редакторе так же приведет к изменению идентификации колонок. Для того, чтобы на другом компьютере вернуться к стандартной нумерации нужно будет просто закрыть текущий документ и открыть другой файл, имеющий стандартное форматирование. Также можно просто выполнить команду «Файл» и выбрать пункт «Создать», далее указать опцию «Новый». Редактор вернется к стандартному обозначению ячеек.
  2. Также нужно понимать, что при изменении идентификации ячеек будет изменен принцип записи формул. Ячейка с формулой примет обозначение RC, а все находящиеся в ней ссылки будут записаны относительно данной ячейки. Например, ячейка, которая находится в той же строке, но в правой колонке будет записана RC[+1]. Соответственно, если ячейка находится в той же колонке, но на одну строку ниже будет записана R[+1]C.
Читать еще:  Как посмотреть и удалить историю в Яндекс Браузере

Рекомендуем использовать в работе только 100% лицензионную версию программы Excel. Заказать со скидкой вы можете у нас, нажмите здесь, чтобы узнать цены.

    Для того, чтобы применить цифровое обозначение колонок таблицы нажмите меню «Файл», в появившемся списке выберите команду «Параметры». Будет открыто диалоговое окно «Параметры Excel», в нем нужно перейти на вкладку «Формулы», найдите группу команд «Работа с формулами». Строка «Стиль ссылок R1C1»

В данной группе найдите строку «Стиль ссылок R1C1» и поставьте отметку в соответствующий чекбокс (дополнительную информацию о данной функции можно узнать, наведя мышку на иконку со знаком вопроса возле этого пункта). После нажатия на кнопку ОК, в открытом диалоговом окне настроек, колонки таблицы будут обозначаться цифрами. Для того, чтобы вернуть стандартное обозначение придется снова открыть окно настроек и снять отметку возле соответствующего поля. Стоит заметить, что при изменении данных настроек все формулы, находящиеся в открытом документе, автоматически будут изменены.

Метод 2: настройки в Режиме разработчика

Прежде, чем приступить к выполнению действий, описанных в данном методе, необходимо активировать режим Разработчика, так как по умолчанию он выключен.

  • заходим в параметры программы (порядок действий описан выше);
  • переходим в раздел “Настроить ленту”, в правой части окна находим пункт “Разработчик”, ставим напротив него галочку и щелкаем OK.

Теперь можно перейти к основному алгоритму действий:

    Переходим во вкладку “Разработчик”, в левой части которой щелкаем по кнопке “Visual Basic”. Также, вместо этого можно воспользоваться комбинацией клавиш Alt+F11.

Ссылка на основную публикацию
Статьи c упоминанием слов:
Adblock
detector